problem with the calibrate.py script

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with the calibrate.py script

Chris Efstathiou
Hi.

I now found another problem and i need some help.

When i am trying to use the calibrate.py script i get the following error

hendrix@hendrix-HP-Compaq-8200-Elite-SFF-PC:~$
/home/hendrix/paparazzi/sw/tools/calibration/calibrate.py --help
Traceback (most recent call last):
   File "/home/hendrix/paparazzi/sw/tools/calibration/calibrate.py",
line 28, in <module>
     import scipy
ImportError: No module named 'scipy'
hendrix@hendrix-HP-Compaq-8200-Elite-SFF-PC:~$

I have the scipy installed

hendrix@hendrix-HP-Compaq-8200-Elite-SFF-PC:~$ sudo apt-get install
python-scipy

[sudo] password for hendrix:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-scipy is already the newest version (0.17.0-1).
The following packages were automatically installed and are no longer
required:
   a11y-profile-manager account-plugin-aim account-plugin-jabber
etc. etc. etc.

Any help welcomed.


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: problem with the calibrate.py script

Yannick Jestin
I suspect you have multiple versions of python installed. calibrate.py requires python3   (#!/usr/bin/env python3), and I suspect that
you are working on a debian/ubuntu for which python-scipy package is related to python2. You might want to try to install the python3-scipy package.

Let us know !


  Y.


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel