installation error on Ubuntu 18.04 lts amd64 bionic

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

installation error on Ubuntu 18.04 lts amd64 bionic

Chris Efstathiou
Hi.
I get an error while trying to install paparazzi on my new laptop loaded with ubuntu 18.04 LTS bionic using the all in one command
sudo add-apt-repository -y ppa:paparazzi-uav/ppa && sudo add-apt-repository -y ppa:team-gcc-arm-embedded/ppa && sudo apt-get update && sudo apt-get -f -y install paparazzi-dev paparazzi-jsbsim gcc-arm-embedded && cd ~ && git clone --origin upstream https://github.com/paparazzi/paparazzi.git && cd ~/paparazzi && git remote update -p && git checkout -b v5.14 upstream/v5.14 && sudo cp conf/system/udev/rules/*.rules /etc/udev/rules.d/ && sudo udevadm control --reload-rules && make && ./paparazzi

Any help welcomed!
Here is the error part, probably the gcc arm embedded.
Unpacking paparazzi-jsbsim (1.5-4~bionic) ...
Preparing to unpack .../gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb ...
Unpacking gcc-arm-embedded (7-2018q2-1~bionic1) ...
dpkg: error processing archive /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libcc1.so.0.0.0', which is also in package gcc-avr 1:5.4.0+Atmel3.6.0-1build1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Selecting previously unselected package paparazzi-dev.
Preparing to unpack .../paparazzi-dev_3.26_all.deb ...
Unpacking paparazzi-dev (3.26) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hendrix@hendrix-PU551LA:~/paparazzi$

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: installation error on Ubuntu 18.04 lts amd64 bionic

Hector Garcia de Marina-2
Hej Hendrix,

I am with 18.04 LTS as well. You might remove the team-gcc-arm-embedded repository and install the gcc-arm that comes from Ubuntu. I am compiling the firmware with it and so far no problems.

On Sat, Aug 17, 2019 at 7:01 PM hendrixgr . <[hidden email]> wrote:
Hi.
I get an error while trying to install paparazzi on my new laptop loaded with ubuntu 18.04 LTS bionic using the all in one command
sudo add-apt-repository -y ppa:paparazzi-uav/ppa && sudo add-apt-repository -y ppa:team-gcc-arm-embedded/ppa && sudo apt-get update && sudo apt-get -f -y install paparazzi-dev paparazzi-jsbsim gcc-arm-embedded && cd ~ && git clone --origin upstream https://github.com/paparazzi/paparazzi.git && cd ~/paparazzi && git remote update -p && git checkout -b v5.14 upstream/v5.14 && sudo cp conf/system/udev/rules/*.rules /etc/udev/rules.d/ && sudo udevadm control --reload-rules && make && ./paparazzi

Any help welcomed!
Here is the error part, probably the gcc arm embedded.
Unpacking paparazzi-jsbsim (1.5-4~bionic) ...
Preparing to unpack .../gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb ...
Unpacking gcc-arm-embedded (7-2018q2-1~bionic1) ...
dpkg: error processing archive /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libcc1.so.0.0.0', which is also in package gcc-avr 1:5.4.0+Atmel3.6.0-1build1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Selecting previously unselected package paparazzi-dev.
Preparing to unpack .../paparazzi-dev_3.26_all.deb ...
Unpacking paparazzi-dev (3.26) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hendrix@hendrix-PU551LA:~/paparazzi$
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


--
Héctor García de Marina

New personal website! https://sites.google.com/view/hgdemarina

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: installation error on Ubuntu 18.04 lts amd64 bionic SOLVED

Chris Efstathiou

Success!

I installed paparazzi by following the steps you suggested, thank you very much.

Chris.

On 17/8/19 8:40 μ.μ., Hector Garcia de Marina wrote:
Hej Hendrix,

I am with 18.04 LTS as well. You might remove the team-gcc-arm-embedded repository and install the gcc-arm that comes from Ubuntu. I am compiling the firmware with it and so far no problems.

On Sat, Aug 17, 2019 at 7:01 PM hendrixgr . <[hidden email]> wrote:
Hi.
I get an error while trying to install paparazzi on my new laptop loaded with ubuntu 18.04 LTS bionic using the all in one command
sudo add-apt-repository -y ppa:paparazzi-uav/ppa && sudo add-apt-repository -y ppa:team-gcc-arm-embedded/ppa && sudo apt-get update && sudo apt-get -f -y install paparazzi-dev paparazzi-jsbsim gcc-arm-embedded && cd ~ && git clone --origin upstream https://github.com/paparazzi/paparazzi.git && cd ~/paparazzi && git remote update -p && git checkout -b v5.14 upstream/v5.14 && sudo cp conf/system/udev/rules/*.rules /etc/udev/rules.d/ && sudo udevadm control --reload-rules && make && ./paparazzi

Any help welcomed!
Here is the error part, probably the gcc arm embedded.
Unpacking paparazzi-jsbsim (1.5-4~bionic) ...
Preparing to unpack .../gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb ...
Unpacking gcc-arm-embedded (7-2018q2-1~bionic1) ...
dpkg: error processing archive /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libcc1.so.0.0.0', which is also in package gcc-avr 1:5.4.0+Atmel3.6.0-1build1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Selecting previously unselected package paparazzi-dev.
Preparing to unpack .../paparazzi-dev_3.26_all.deb ...
Unpacking paparazzi-dev (3.26) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gcc-arm-embedded_7-2018q2-1~bionic1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hendrix@hendrix-PU551LA:~/paparazzi$
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


--
Héctor García de Marina

New personal website! https://sites.google.com/view/hgdemarina

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel