a small typo inside the nav_catapult.xml file

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

a small typo inside the nav_catapult.xml file

Chris
Hi.
I just found a typo, nothing serious but it got me scratching my head because
i couldn't get my catapult initial settings inside the airframe file defined after
i pasted the nav_catapult.xml definitions in the airframe file :-)
The error in in the INITAL_PITCH

    </description>
    <section name="CATAPULT" prefix="NAV_CATAPULT_">
      <define name="ACCELERATION_THRESHOLD" value="1.5" description="acceleration threshold in multiples of g" unit="g"/>
      <define name="ACCELERATION_DETECTION" value="5" description="number acceleration measurments above threshold for launch detection"/>
      <define name="MOTOR_DELAY" value="0.75" description="delay until motor is turned on in seconds" unit="s"/>
      <define name="HEADING_DELAY" value="3.0" description="delay until heading is unlocked in seconds" unit="s"/>
      <define name="INITAL_PITCH" value="0.175" description="inital pitch in radians (default 10deg)" unit="rad"/>
      <define name="INITIAL_THROTTLE" value="1.0" description="initial throttle (0.0 to 1.0)" unit="%"/>
      <define name="CLIMB_DISTANCE" value="300" description="distance of the climb waypoint in front of the catapult" unit="m"/>
      <define name="TIMEOUT" value="30." description="timeout to disarm the high freq module" unit="s"/>
    </section>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: a small typo inside the nav_catapult.xml file

flixr
Administrator
Thx! Fixed...

On Sat, Jun 18, 2016 at 4:42 PM, hendrixgr . <[hidden email]> wrote:
Hi.
I just found a typo, nothing serious but it got me scratching my head because
i couldn't get my catapult initial settings inside the airframe file defined after
i pasted the nav_catapult.xml definitions in the airframe file :-)
The error in in the INITAL_PITCH

    </description>
    <section name="CATAPULT" prefix="NAV_CATAPULT_">
      <define name="ACCELERATION_THRESHOLD" value="1.5" description="acceleration threshold in multiples of g" unit="g"/>
      <define name="ACCELERATION_DETECTION" value="5" description="number acceleration measurments above threshold for launch detection"/>
      <define name="MOTOR_DELAY" value="0.75" description="delay until motor is turned on in seconds" unit="s"/>
      <define name="HEADING_DELAY" value="3.0" description="delay until heading is unlocked in seconds" unit="s"/>
      <define name="INITAL_PITCH" value="0.175" description="inital pitch in radians (default 10deg)" unit="rad"/>
      <define name="INITIAL_THROTTLE" value="1.0" description="initial throttle (0.0 to 1.0)" unit="%"/>
      <define name="CLIMB_DISTANCE" value="300" description="distance of the climb waypoint in front of the catapult" unit="m"/>
      <define name="TIMEOUT" value="30." description="timeout to disarm the high freq module" unit="s"/>
    </section>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Loading...