Xsens MTi-G-700

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Xsens MTi-G-700

Lazy
Hi gang

Tell me please, who know…
Why system not compile with MTi-G-700 IMU from Xsens?
Problem on makefile or xsens700.c module?
Is somebody works to fix this?

Sincerely you

Vladimir
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Gautier Hattenberger-3
Hi,

Can you provide more information about your paparazzi version, hardware
configuration and error message when compiling ?

Thanks

Gautier

Le 24/09/2014 17:42, Lazy a écrit :

> Hi gang
>
> Tell me please, who know…
> Why system not compile with MTi-G-700 IMU from Xsens?
> Problem on makefile or xsens700.c module?
> Is somebody works to fix this?
>
> Sincerely you
>
> Vladimir
>
>
>
>
> --
> View this message in context: http://lists.paparazziuav.org/Xsens-MTi-G-700-tp16170.html
> Sent from the paparazzi-devel mailing list archive at Nabble.com.
>
> _______________________________________________
> Paparazzi-devel mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Lazy
Dear Gautier
Now i'm install a 5.2 stable and testing.

Many thanks for replay.

Sincerely
Vladimir
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Lazy
In reply to this post by Gautier Hattenberger-3
Dear Gautier
Modules compiled and uploaded correctly, but...
After 3D fix i receive messages: Non_normal_number:_nan_in_'1_ATTITUDE_nan_nan_nan'
Some time also: File "pprz.ml", line 523, characters 4-10: Assertion failed
PFD frozen in strange position, any reaction for movement.
Hardware is: YAPA 2 board, 3DR modems in transparent mode, Xsens MTi-700 IMU.
Firmware section of my config:
<modules main_freq="100">
        </modules>
        <firmware name="fixedwing">
                <target name="ap" board="yapa_2.0"/>
                <target name="sim" board="pc"/>
                <define name="STRONG_WIND"/>
                <define name="WIND_INFO"/>
                <define name="WIND_INFO_RET"/>
                <define name="LOITER_TRIM"/>
                <define name="TUNE_AGRESSIVE_CLIMB"/>
                <define name="AGR_CLIMB"/>
                <define name="ALT_KALMAN"/>
                <define name="USE_GPS_XSENS"/>

               
                <configure name="SYS_TIME_LED" value="1"/>
                <configure name="GPS_LED" value="2"/>

               
                <subsystem name="radio_control" type="ppm"/>

               
                <subsystem name="telemetry" type="transparent">
                        <configure name="MODEM_BAUD" value="B19200"/>
                        <configure name="MODEM_PORT" value="UART1"/>
                </subsystem>

               
                <subsystem name="control"/>

               
                 <subsystem name="navigation"/>
                <subsystem name="ins" type="xsens700">
                        <configure name="XSENS_UART_NR" value="0"/>
                        <configure name="XSENS_UART_BAUD" value="B230400"/>
                </subsystem>

        </firmware>


Sincerely you
Vladimir
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Lazy
In reply to this post by Lazy
Dear Gautier
Fixed. I put wrong parameters into IMU.

Sincerely
Vlad
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Gautier Hattenberger-3
Ok, nice to hear that it is working for you now.

Gautier

Le 28/09/2014 20:33, Lazy a écrit :

> Dear Gautier
> Fixed. I put wrong parameters into IMU.
>
> Sincerely
> Vlad
>
>
>
> --
> View this message in context: http://lists.paparazziuav.org/Xsens-MTi-G-700-tp16170p16189.html
> Sent from the paparazzi-devel mailing list archive at Nabble.com.
>
> _______________________________________________
> Paparazzi-devel mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Xsens MTi-G-700

Lazy
Many thanks Gautier

So, next - field tests.

Sincerely
Vlad

P.S.
GPG_LED not blinking :)