Roll and Heading problem ,Help me‏

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Roll and Heading problem ,Help me‏

Yu_Ming
Hello,everyone 
     I am Taiwan Student. I start to learn using paparazzi about 2 month and encounter some strange problems.I use Paparazzi 5.2 version and Lisa/m 2.0. 
    When I  switch to Auto2 mode ,the aileron have random movement (other servos has normal movement ) ,but it is  acts normal in Manuel and AUTO1 mode.I check the desired roll in message when execute in Auto2 mode.It changes at random  +/-30 deg range.Another,I open the server and I have to put IMU x-axis points to north otherwise I get error heading on GCS. Anyone know why and how to fix it. 

Thanks for your help and Merry Christmas. 

Yu_Ming

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Roll and Heading problem ,Help me‏

agressiva
have you check if magnetometer are working ?
You can see the magnetometer values in messages window after change the telemetry to raw_sensors or scaled sensors.

if its working, have you calibrated the magnetometer ?

About servo movement when in AUTO2, its normal when the gps are locked and the plane stay stoped.





From: [hidden email]
To: [hidden email]
Date: Sun, 14 Dec 2014 23:35:23 +0800
Subject: [Paparazzi-devel] Roll and Heading problem ,Help me‏

Hello,everyone 
     I am Taiwan Student. I start to learn using paparazzi about 2 month and encounter some strange problems.I use Paparazzi 5.2 version and Lisa/m 2.0. 
    When I  switch to Auto2 mode ,the aileron have random movement (other servos has normal movement ) ,but it is  acts normal in Manuel and AUTO1 mode.I check the desired roll in message when execute in Auto2 mode.It changes at random  +/-30 deg range.Another,I open the server and I have to put IMU x-axis points to north otherwise I get error heading on GCS. Anyone know why and how to fix it. 

Thanks for your help and Merry Christmas. 

Yu_Ming

_______________________________________________ Paparazzi-devel mailing list [hidden email] https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Roll and Heading problem ,Help me‏

Yu_Ming
This post has NOT been accepted by the mailing list yet.
Hi,Eduardo lavratti
   Thanks for your help.The heading problem is solved as your suggestion.
And you say " the gps are locked and the plane stay stoped", it is mean the plane has to have a speed ? On ground,I simulate to  fly. I set a waypoint far away from me and let my plane fly to it in auto2 mode (plane still on the ground).It has same  movement.Is it normal?
   About calibrated the magnetometer.I have 3.6m big plane, can I calibrate the magnetometer by only spin  the Lisa/M board  2 circle around 3 axes but not whole plane?
Thank you very much for your help and reply.
Yu_Ming