Re: AUTO2 Standby throttle management

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: AUTO2 Standby throttle management

josibarns
I have followed Reto's advice and things improved quite a bit. Thanks again!

In detail I lowered AUTO_THROTTLE_PGAIN and IGAIN, and increased AUTO_THROTTLE_PITCH_OF_VZ_PGAIN and ALTITUDE_PGAIN.

However, It is still far from perfect, the plane, while flying standby, drops 15m and tries to catch up then drops again. It looks like something is wrong with my pitch loop but it doesn't seem to be the gain. Attached is the flight log and a screenshot of what I think is the issue.


Inline image 1

And here my current gains.
(Umarim v2, fixedwing)

<!-- ************************* GAINS ************************* -->

  <section name="VERTICAL CONTROL" prefix="V_CTL_">
    <define name="POWER_CTL_BAT_NOMINAL" value="14.8" unit="volt"/>
    <!-- outer loop proportional gain -->
    <define name="ALTITUDE_PGAIN"        value="0.051"/> <!-- climb speed in m/s e.g. 10 m too low x 0.1 alt gain = climb_command at 1 m/s-->
    <!-- outer loop saturation -->
    <define name="ALTITUDE_MAX_CLIMB"    value="5."/> <!-- maximum climb speed in m/s -->

    <!-- auto throttle inner loop -->
    <define name="AUTO_THROTTLE_NOMINAL_CRUISE_THROTTLE"  value="0.45"/>
    <define name="AUTO_THROTTLE_MIN_CRUISE_THROTTLE"      value="0.25"/>
    <define name="AUTO_THROTTLE_MAX_CRUISE_THROTTLE"      value="0.70"/>
    <define name="AUTO_THROTTLE_LOITER_TRIM"              value="1500"/>
    <define name="AUTO_THROTTLE_DASH_TRIM"                value="-2500"/>
    <define name="AUTO_THROTTLE_CLIMB_THROTTLE_INCREMENT" value="0.15" unit="%/(m/s)"/>
    <define name="AUTO_THROTTLE_PGAIN"                    value="0.006"/>
    <define name="AUTO_THROTTLE_IGAIN"                    value="0.016"/>
    <define name="AUTO_THROTTLE_PITCH_OF_VZ_PGAIN"        value="0.09"/>
   
    <define name="THROTTLE_SLEW_LIMITER" value="2" unit="s"/>
  </section>

 <section name="HORIZONTAL CONTROL" prefix="H_CTL_">
    <define name="COURSE_PGAIN" value="1.219"/>
    <define name="COURSE_DGAIN" value="0.219"/>
    <define name="ROLL_MAX_SETPOINT"  value="RadOfDeg(60)" />
    <define name="PITCH_MAX_SETPOINT" value="RadOfDeg(40)"/>
    <define name="PITCH_MIN_SETPOINT" value="RadOfDeg(-40)"/>
    <define name="PITCH_PGAIN" value="6000"/>
    <define name="PITCH_DGAIN" value="1.5"/>
    <define name="ELEVATOR_OF_ROLL" value="1250"/>
    <define name="ROLL_ATTITUDE_GAIN" value="7500"/>
    <define name="ROLL_RATE_GAIN"     value="1500"/>
  </section>

  <section name="AGGRESSIVE" prefix="AGR_">
    <define name="BLEND_START" value="30"/><!-- Altitude Error to Initiate Aggressive Climb CANNOT BE ZERO!!-->
    <define name="BLEND_END" value="15"/><!-- Altitude Error to Blend Aggressive to Regular Climb Modes  CANNOT BE ZERO!!-->
    <define name="CLIMB_THROTTLE" value="0.80"/><!-- Gaz for Aggressive Climb -->
    <define name="CLIMB_PITCH" value="0.4"/><!-- Pitch for Aggressive Climb -->
    <define name="DESCENT_THROTTLE" value="0.1"/><!-- Gaz for Aggressive Decent -->
    <define name="DESCENT_PITCH" value="-0.25"/><!-- Pitch for Aggressive Decent -->
    <define name="CLIMB_NAV_RATIO" value="0.8"/><!-- Percent Navigation for Altitude Error Equal to Start Altitude -->
    <define name="DESCENT_NAV_RATIO" value="1.0"/>
  </section>

On Thu, Jul 25, 2013 at 11:29 PM, <[hidden email]> wrote:

Date: Thu, 25 Jul 2013 19:38:39 +0200
From: Joseph Muhlhausen <[hidden email]>
To: [hidden email]
Subject: Re: [Paparazzi-devel] AUTO2 Standby throttle management
Message-ID:
        <CAL9U2bJxVe7gbX+KhrT2_ao-wRbe8AL3kdO=[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"

Thanks a lot Reto,

I will try to tweak the gains and see if it solves the issue.

Joseph

 Thu, 25 Jul 2013 13:19:35 Reto B?ttner
>
> Hi Joseph
>
> That might be a problem in altitude control, probably just a tuning issue.
> Altitude is controlled both by pitch and throttle. In your case pitch
> control seems not be sensitive enough and throttle control too aggressive.
> Try enhancing the pitch gains and reducing the throttle gains. Maybe
> vertical control is generally to weak and you fly permanently in the
> aggressive flightmodes, try enhancing altitude_pgain. Additionally you
> might give more margin (blend_start and blend_end) in the aggressive
> section, especially until the vertical controller is well tuned. For more
> detailed analysis a log would be needed.
>
> Regards and good luck
> Reto
>
>
>
> 2013/7/25 Joseph Muhlhausen <[hidden email]>
>
> > Hi all,
> >
> > I did an AUTO2 Standby test yesterday and the plane accelerates to full
> > throttle for half the circle and repeats the pattern indefinitly
> >
> > here is the video
> > https://www.dropbox.com/s/g3sl68myu15lh7g/VID_20130626_163444.mp4
> >
> > I'm using 4.2 with the ctl_basic.xml control. I couldn't get a log of the
> > flight as my ground wasn't properly connected to the antenna.
> >
> > Any idea where that might come from? I'm not using an airspeed sensor but
> > I have one at my disposal if needed, I just want to keep things simple.
> >
> > Best,
> >
> > Joseph
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nongnu.org/archive/html/paparazzi-devel/attachments/20130725/628d60fc/attachment.html>


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

13_08_12__15_49_34.data (8M) Download Attachment
13_08_12__15_49_34.log (625K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: AUTO2 Standby throttle management

Reto Büttner
Hi Joseph

When a PID control is not stable I usually try to set the I-gain to zero. I therefore recommend to reduce AUTO_THROTTLE_IGAIN further or set to zero. And your P-gains might be further enlarged.

When tuning Paparazzi it is important to tune AUTO1 well before approaching AUTO2. The plane must fly stable in AUTO1 (no oscillations) and react quickly to control inputs (no sluggish behaviour). Does your plane do so?

I hope that helps. Unfortunately I cannot look at your log right now due to system problems on my side for in depth analysis.

Regards, Reto



2013/8/13 Joseph Muhlhausen <[hidden email]>
I have followed Reto's advice and things improved quite a bit. Thanks again!

In detail I lowered AUTO_THROTTLE_PGAIN and IGAIN, and increased AUTO_THROTTLE_PITCH_OF_VZ_PGAIN and ALTITUDE_PGAIN.

However, It is still far from perfect, the plane, while flying standby, drops 15m and tries to catch up then drops again. It looks like something is wrong with my pitch loop but it doesn't seem to be the gain. Attached is the flight log and a screenshot of what I think is the issue.


Inline image 1

And here my current gains.
(Umarim v2, fixedwing)

<!-- ************************* GAINS ************************* -->

  <section name="VERTICAL CONTROL" prefix="V_CTL_">
    <define name="POWER_CTL_BAT_NOMINAL" value="14.8" unit="volt"/>
    <!-- outer loop proportional gain -->
    <define name="ALTITUDE_PGAIN"        value="0.051"/> <!-- climb speed in m/s e.g. 10 m too low x 0.1 alt gain = climb_command at 1 m/s-->
    <!-- outer loop saturation -->
    <define name="ALTITUDE_MAX_CLIMB"    value="5."/> <!-- maximum climb speed in m/s -->

    <!-- auto throttle inner loop -->
    <define name="AUTO_THROTTLE_NOMINAL_CRUISE_THROTTLE"  value="0.45"/>
    <define name="AUTO_THROTTLE_MIN_CRUISE_THROTTLE"      value="0.25"/>
    <define name="AUTO_THROTTLE_MAX_CRUISE_THROTTLE"      value="0.70"/>
    <define name="AUTO_THROTTLE_LOITER_TRIM"              value="1500"/>
    <define name="AUTO_THROTTLE_DASH_TRIM"                value="-2500"/>
    <define name="AUTO_THROTTLE_CLIMB_THROTTLE_INCREMENT" value="0.15" unit="%/(m/s)"/>
    <define name="AUTO_THROTTLE_PGAIN"                    value="0.006"/>
    <define name="AUTO_THROTTLE_IGAIN"                    value="0.016"/>
    <define name="AUTO_THROTTLE_PITCH_OF_VZ_PGAIN"        value="0.09"/>
   
    <define name="THROTTLE_SLEW_LIMITER" value="2" unit="s"/>
  </section>

 <section name="HORIZONTAL CONTROL" prefix="H_CTL_">
    <define name="COURSE_PGAIN" value="1.219"/>
    <define name="COURSE_DGAIN" value="0.219"/>
    <define name="ROLL_MAX_SETPOINT"  value="RadOfDeg(60)" />
    <define name="PITCH_MAX_SETPOINT" value="RadOfDeg(40)"/>
    <define name="PITCH_MIN_SETPOINT" value="RadOfDeg(-40)"/>
    <define name="PITCH_PGAIN" value="6000"/>
    <define name="PITCH_DGAIN" value="1.5"/>
    <define name="ELEVATOR_OF_ROLL" value="1250"/>
    <define name="ROLL_ATTITUDE_GAIN" value="7500"/>
    <define name="ROLL_RATE_GAIN"     value="1500"/>
  </section>

  <section name="AGGRESSIVE" prefix="AGR_">
    <define name="BLEND_START" value="30"/><!-- Altitude Error to Initiate Aggressive Climb CANNOT BE ZERO!!-->
    <define name="BLEND_END" value="15"/><!-- Altitude Error to Blend Aggressive to Regular Climb Modes  CANNOT BE ZERO!!-->
    <define name="CLIMB_THROTTLE" value="0.80"/><!-- Gaz for Aggressive Climb -->
    <define name="CLIMB_PITCH" value="0.4"/><!-- Pitch for Aggressive Climb -->
    <define name="DESCENT_THROTTLE" value="0.1"/><!-- Gaz for Aggressive Decent -->
    <define name="DESCENT_PITCH" value="-0.25"/><!-- Pitch for Aggressive Decent -->
    <define name="CLIMB_NAV_RATIO" value="0.8"/><!-- Percent Navigation for Altitude Error Equal to Start Altitude -->
    <define name="DESCENT_NAV_RATIO" value="1.0"/>
  </section>

On Thu, Jul 25, 2013 at 11:29 PM, <[hidden email]> wrote:

Date: Thu, 25 Jul 2013 19:38:39 +0200
From: Joseph Muhlhausen <[hidden email]>
To: [hidden email]
Subject: Re: [Paparazzi-devel] AUTO2 Standby throttle management
Message-ID:
        <CAL9U2bJxVe7gbX+KhrT2_ao-wRbe8AL3kdO=[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"

Thanks a lot Reto,

I will try to tweak the gains and see if it solves the issue.

Joseph

 Thu, 25 Jul 2013 13:19:35 Reto B?ttner
>
> Hi Joseph
>
> That might be a problem in altitude control, probably just a tuning issue.
> Altitude is controlled both by pitch and throttle. In your case pitch
> control seems not be sensitive enough and throttle control too aggressive.
> Try enhancing the pitch gains and reducing the throttle gains. Maybe
> vertical control is generally to weak and you fly permanently in the
> aggressive flightmodes, try enhancing altitude_pgain. Additionally you
> might give more margin (blend_start and blend_end) in the aggressive
> section, especially until the vertical controller is well tuned. For more
> detailed analysis a log would be needed.
>
> Regards and good luck
> Reto
>
>
>
> 2013/7/25 Joseph Muhlhausen <[hidden email]>
>
> > Hi all,
> >
> > I did an AUTO2 Standby test yesterday and the plane accelerates to full
> > throttle for half the circle and repeats the pattern indefinitly
> >
> > here is the video
> > https://www.dropbox.com/s/g3sl68myu15lh7g/VID_20130626_163444.mp4
> >
> > I'm using 4.2 with the ctl_basic.xml control. I couldn't get a log of the
> > flight as my ground wasn't properly connected to the antenna.
> >
> > Any idea where that might come from? I'm not using an airspeed sensor but
> > I have one at my disposal if needed, I just want to keep things simple.
> >
> > Best,
> >
> > Joseph
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nongnu.org/archive/html/paparazzi-devel/attachments/20130725/628d60fc/attachment.html>


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: AUTO2 Standby throttle management

David Conger-5
Also how does the plane fly in manual? If the plane is not mechanically trimmed to fly straight and level at cruise throttle you are going to give an unstable airplane to the autopilot. I always get the aircraft to be stable (ie hands off straight and level) before worrying about AUTO1/2.

Maybe you have already done this. Just a thought as for me the defaults are very good.

David

On Aug 17, 2013, at 7:34 AM, Reto Büttner <[hidden email]> wrote:

Hi Joseph

When a PID control is not stable I usually try to set the I-gain to zero. I therefore recommend to reduce AUTO_THROTTLE_IGAIN further or set to zero. And your P-gains might be further enlarged.

When tuning Paparazzi it is important to tune AUTO1 well before approaching AUTO2. The plane must fly stable in AUTO1 (no oscillations) and react quickly to control inputs (no sluggish behaviour). Does your plane do so?

I hope that helps. Unfortunately I cannot look at your log right now due to system problems on my side for in depth analysis.

Regards, Reto



2013/8/13 Joseph Muhlhausen <[hidden email]>
I have followed Reto's advice and things improved quite a bit. Thanks again!

In detail I lowered AUTO_THROTTLE_PGAIN and IGAIN, and increased AUTO_THROTTLE_PITCH_OF_VZ_PGAIN and ALTITUDE_PGAIN.

However, It is still far from perfect, the plane, while flying standby, drops 15m and tries to catch up then drops again. It looks like something is wrong with my pitch loop but it doesn't seem to be the gain. Attached is the flight log and a screenshot of what I think is the issue.


<Problem pitch Aug11.png>

And here my current gains.
(Umarim v2, fixedwing)

<!-- ************************* GAINS ************************* -->

  <section name="VERTICAL CONTROL" prefix="V_CTL_">
    <define name="POWER_CTL_BAT_NOMINAL" value="14.8" unit="volt"/>
    <!-- outer loop proportional gain -->
    <define name="ALTITUDE_PGAIN"        value="0.051"/> <!-- climb speed in m/s e.g. 10 m too low x 0.1 alt gain = climb_command at 1 m/s-->
    <!-- outer loop saturation -->
    <define name="ALTITUDE_MAX_CLIMB"    value="5."/> <!-- maximum climb speed in m/s -->

    <!-- auto throttle inner loop -->
    <define name="AUTO_THROTTLE_NOMINAL_CRUISE_THROTTLE"  value="0.45"/>
    <define name="AUTO_THROTTLE_MIN_CRUISE_THROTTLE"      value="0.25"/>
    <define name="AUTO_THROTTLE_MAX_CRUISE_THROTTLE"      value="0.70"/>
    <define name="AUTO_THROTTLE_LOITER_TRIM"              value="1500"/>
    <define name="AUTO_THROTTLE_DASH_TRIM"                value="-2500"/>
    <define name="AUTO_THROTTLE_CLIMB_THROTTLE_INCREMENT" value="0.15" unit="%/(m/s)"/>
    <define name="AUTO_THROTTLE_PGAIN"                    value="0.006"/>
    <define name="AUTO_THROTTLE_IGAIN"                    value="0.016"/>
    <define name="AUTO_THROTTLE_PITCH_OF_VZ_PGAIN"        value="0.09"/>
   
    <define name="THROTTLE_SLEW_LIMITER" value="2" unit="s"/>
  </section>

 <section name="HORIZONTAL CONTROL" prefix="H_CTL_">
    <define name="COURSE_PGAIN" value="1.219"/>
    <define name="COURSE_DGAIN" value="0.219"/>
    <define name="ROLL_MAX_SETPOINT"  value="RadOfDeg(60)" />
    <define name="PITCH_MAX_SETPOINT" value="RadOfDeg(40)"/>
    <define name="PITCH_MIN_SETPOINT" value="RadOfDeg(-40)"/>
    <define name="PITCH_PGAIN" value="6000"/>
    <define name="PITCH_DGAIN" value="1.5"/>
    <define name="ELEVATOR_OF_ROLL" value="1250"/>
    <define name="ROLL_ATTITUDE_GAIN" value="7500"/>
    <define name="ROLL_RATE_GAIN"     value="1500"/>
  </section>

  <section name="AGGRESSIVE" prefix="AGR_">
    <define name="BLEND_START" value="30"/><!-- Altitude Error to Initiate Aggressive Climb CANNOT BE ZERO!!-->
    <define name="BLEND_END" value="15"/><!-- Altitude Error to Blend Aggressive to Regular Climb Modes  CANNOT BE ZERO!!-->
    <define name="CLIMB_THROTTLE" value="0.80"/><!-- Gaz for Aggressive Climb -->
    <define name="CLIMB_PITCH" value="0.4"/><!-- Pitch for Aggressive Climb -->
    <define name="DESCENT_THROTTLE" value="0.1"/><!-- Gaz for Aggressive Decent -->
    <define name="DESCENT_PITCH" value="-0.25"/><!-- Pitch for Aggressive Decent -->
    <define name="CLIMB_NAV_RATIO" value="0.8"/><!-- Percent Navigation for Altitude Error Equal to Start Altitude -->
    <define name="DESCENT_NAV_RATIO" value="1.0"/>
  </section>

On Thu, Jul 25, 2013 at 11:29 PM, <[hidden email]> wrote:

Date: Thu, 25 Jul 2013 19:38:39 +0200
From: Joseph Muhlhausen <[hidden email]>
To: [hidden email]
Subject: Re: [Paparazzi-devel] AUTO2 Standby throttle management
Message-ID:
        <CAL9U2bJxVe7gbX+KhrT2_ao-wRbe8AL3kdO=[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"

Thanks a lot Reto,

I will try to tweak the gains and see if it solves the issue.

Joseph

 Thu, 25 Jul 2013 13:19:35 Reto B?ttner
>
> Hi Joseph
>
> That might be a problem in altitude control, probably just a tuning issue.
> Altitude is controlled both by pitch and throttle. In your case pitch
> control seems not be sensitive enough and throttle control too aggressive.
> Try enhancing the pitch gains and reducing the throttle gains. Maybe
> vertical control is generally to weak and you fly permanently in the
> aggressive flightmodes, try enhancing altitude_pgain. Additionally you
> might give more margin (blend_start and blend_end) in the aggressive
> section, especially until the vertical controller is well tuned. For more
> detailed analysis a log would be needed.
>
> Regards and good luck
> Reto
>
>
>
> 2013/7/25 Joseph Muhlhausen <[hidden email]>
>
> > Hi all,
> >
> > I did an AUTO2 Standby test yesterday and the plane accelerates to full
> > throttle for half the circle and repeats the pattern indefinitly
> >
> > here is the video
> > https://www.dropbox.com/s/g3sl68myu15lh7g/VID_20130626_163444.mp4
> >
> > I'm using 4.2 with the ctl_basic.xml control. I couldn't get a log of the
> > flight as my ground wasn't properly connected to the antenna.
> >
> > Any idea where that might come from? I'm not using an airspeed sensor but
> > I have one at my disposal if needed, I just want to keep things simple.
> >
> > Best,
> >
> > Joseph
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nongnu.org/archive/html/paparazzi-devel/attachments/20130725/628d60fc/attachment.html>


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: AUTO2 Standby throttle management

josibarns
Hi Reto, David,

My ins neutral point was off by 1.8 degrees and I had a little bit of oscillation on roll. I spent yesterday fixing this and I'll trying tuning the navigation loop again next week to see if it makes a difference.

Regarding Igain reading PID loop theory I thought Igain was off when its value is infinite and maximum when equal to zero. 


Joseph



On Sat, Aug 17, 2013 at 6:09 PM, David Conger <[hidden email]> wrote:
Also how does the plane fly in manual? If the plane is not mechanically trimmed to fly straight and level at cruise throttle you are going to give an unstable airplane to the autopilot. I always get the aircraft to be stable (ie hands off straight and level) before worrying about AUTO1/2.

Maybe you have already done this. Just a thought as for me the defaults are very good.

David

On Aug 17, 2013, at 7:34 AM, Reto Büttner <[hidden email]> wrote:

Hi Joseph

When a PID control is not stable I usually try to set the I-gain to zero. I therefore recommend to reduce AUTO_THROTTLE_IGAIN further or set to zero. And your P-gains might be further enlarged.

When tuning Paparazzi it is important to tune AUTO1 well before approaching AUTO2. The plane must fly stable in AUTO1 (no oscillations) and react quickly to control inputs (no sluggish behaviour). Does your plane do so?

I hope that helps. Unfortunately I cannot look at your log right now due to system problems on my side for in depth analysis.

Regards, Reto



2013/8/13 Joseph Muhlhausen <[hidden email]>
I have followed Reto's advice and things improved quite a bit. Thanks again!

In detail I lowered AUTO_THROTTLE_PGAIN and IGAIN, and increased AUTO_THROTTLE_PITCH_OF_VZ_PGAIN and ALTITUDE_PGAIN.

However, It is still far from perfect, the plane, while flying standby, drops 15m and tries to catch up then drops again. It looks like something is wrong with my pitch loop but it doesn't seem to be the gain. Attached is the flight log and a screenshot of what I think is the issue.


<Problem pitch Aug11.png>

And here my current gains.
(Umarim v2, fixedwing)

<!-- ************************* GAINS ************************* -->

  <section name="VERTICAL CONTROL" prefix="V_CTL_">
    <define name="POWER_CTL_BAT_NOMINAL" value="14.8" unit="volt"/>
    <!-- outer loop proportional gain -->
    <define name="ALTITUDE_PGAIN"        value="0.051"/> <!-- climb speed in m/s e.g. 10 m too low x 0.1 alt gain = climb_command at 1 m/s-->
    <!-- outer loop saturation -->
    <define name="ALTITUDE_MAX_CLIMB"    value="5."/> <!-- maximum climb speed in m/s -->

    <!-- auto throttle inner loop -->
    <define name="AUTO_THROTTLE_NOMINAL_CRUISE_THROTTLE"  value="0.45"/>
    <define name="AUTO_THROTTLE_MIN_CRUISE_THROTTLE"      value="0.25"/>
    <define name="AUTO_THROTTLE_MAX_CRUISE_THROTTLE"      value="0.70"/>
    <define name="AUTO_THROTTLE_LOITER_TRIM"              value="1500"/>
    <define name="AUTO_THROTTLE_DASH_TRIM"                value="-2500"/>
    <define name="AUTO_THROTTLE_CLIMB_THROTTLE_INCREMENT" value="0.15" unit="%/(m/s)"/>
    <define name="AUTO_THROTTLE_PGAIN"                    value="0.006"/>
    <define name="AUTO_THROTTLE_IGAIN"                    value="0.016"/>
    <define name="AUTO_THROTTLE_PITCH_OF_VZ_PGAIN"        value="0.09"/>
   
    <define name="THROTTLE_SLEW_LIMITER" value="2" unit="s"/>
  </section>

 <section name="HORIZONTAL CONTROL" prefix="H_CTL_">
    <define name="COURSE_PGAIN" value="1.219"/>
    <define name="COURSE_DGAIN" value="0.219"/>
    <define name="ROLL_MAX_SETPOINT"  value="RadOfDeg(60)" />
    <define name="PITCH_MAX_SETPOINT" value="RadOfDeg(40)"/>
    <define name="PITCH_MIN_SETPOINT" value="RadOfDeg(-40)"/>
    <define name="PITCH_PGAIN" value="6000"/>
    <define name="PITCH_DGAIN" value="1.5"/>
    <define name="ELEVATOR_OF_ROLL" value="1250"/>
    <define name="ROLL_ATTITUDE_GAIN" value="7500"/>
    <define name="ROLL_RATE_GAIN"     value="1500"/>
  </section>

  <section name="AGGRESSIVE" prefix="AGR_">
    <define name="BLEND_START" value="30"/><!-- Altitude Error to Initiate Aggressive Climb CANNOT BE ZERO!!-->
    <define name="BLEND_END" value="15"/><!-- Altitude Error to Blend Aggressive to Regular Climb Modes  CANNOT BE ZERO!!-->
    <define name="CLIMB_THROTTLE" value="0.80"/><!-- Gaz for Aggressive Climb -->
    <define name="CLIMB_PITCH" value="0.4"/><!-- Pitch for Aggressive Climb -->
    <define name="DESCENT_THROTTLE" value="0.1"/><!-- Gaz for Aggressive Decent -->
    <define name="DESCENT_PITCH" value="-0.25"/><!-- Pitch for Aggressive Decent -->
    <define name="CLIMB_NAV_RATIO" value="0.8"/><!-- Percent Navigation for Altitude Error Equal to Start Altitude -->
    <define name="DESCENT_NAV_RATIO" value="1.0"/>
  </section>

On Thu, Jul 25, 2013 at 11:29 PM, <[hidden email]> wrote:

Date: Thu, 25 Jul 2013 19:38:39 +0200
From: Joseph Muhlhausen <[hidden email]>
To: [hidden email]
Subject: Re: [Paparazzi-devel] AUTO2 Standby throttle management
Message-ID:
        <CAL9U2bJxVe7gbX+KhrT2_ao-wRbe8AL3kdO=[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"

Thanks a lot Reto,

I will try to tweak the gains and see if it solves the issue.

Joseph

 Thu, 25 Jul 2013 13:19:35 Reto B?ttner
>
> Hi Joseph
>
> That might be a problem in altitude control, probably just a tuning issue.
> Altitude is controlled both by pitch and throttle. In your case pitch
> control seems not be sensitive enough and throttle control too aggressive.
> Try enhancing the pitch gains and reducing the throttle gains. Maybe
> vertical control is generally to weak and you fly permanently in the
> aggressive flightmodes, try enhancing altitude_pgain. Additionally you
> might give more margin (blend_start and blend_end) in the aggressive
> section, especially until the vertical controller is well tuned. For more
> detailed analysis a log would be needed.
>
> Regards and good luck
> Reto
>
>
>
> 2013/7/25 Joseph Muhlhausen <[hidden email]>
>
> > Hi all,
> >
> > I did an AUTO2 Standby test yesterday and the plane accelerates to full
> > throttle for half the circle and repeats the pattern indefinitly
> >
> > here is the video
> > https://www.dropbox.com/s/g3sl68myu15lh7g/VID_20130626_163444.mp4
> >
> > I'm using 4.2 with the ctl_basic.xml control. I couldn't get a log of the
> > flight as my ground wasn't properly connected to the antenna.
> >
> > Any idea where that might come from? I'm not using an airspeed sensor but
> > I have one at my disposal if needed, I just want to keep things simple.
> >
> > Best,
> >
> > Joseph
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.nongnu.org/archive/html/paparazzi-devel/attachments/20130725/628d60fc/attachment.html>


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel