Problem during instalation of paparazzi-arm-multilib

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem during instalation of paparazzi-arm-multilib

flavio_just
Hi guys! I have an old source code that I need to build, it ffrom version 4 of Paparazzi. I have Ubuntu 12.04 LTS. I used the followd commands to install paparazzi-arm-multilib:

sudo add-apt-repository ppa:paparazzi-uav/ppa
sudo apt-get update
sudo apt-get install paparazzi-dev paparazzi-arm-multilib
 
but I get the the message
E: Unable to locate package paparazzi-arm-multilib

I tried to make the source code without this installation but it gives some Ocmpl errors.

Can anyone help me?
Thank you so much guys!
Best regards!
Flávio Justino
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem during instalation of paparazzi-arm-multilib

flixr
Administrator
Hi Flávio,

paparazzi-arm-multilib should still be available for precise, see https://launchpad.net/~paparazzi-uav/+archive/ubuntu/ppa/+packages

apt-cache policy paparazzi-arm-multilib
should print the version and repo where it was found (after apt-get update)

Cheers, Felix

On Tue, May 3, 2016 at 2:02 AM, flavio_just <[hidden email]> wrote:
Hi guys! I have an old source code that I need to build, it ffrom version 4
of Paparazzi. I have Ubuntu 12.04 LTS. I used the followd commands to
install paparazzi-arm-multilib:

sudo add-apt-repository ppa:paparazzi-uav/ppa
sudo apt-get update
sudo apt-get install paparazzi-dev paparazzi-arm-multilib

but I get the the message
E: Unable to locate package paparazzi-arm-multilib

I tried to make the source code without this installation but it gives some
Ocmpl errors.

Can anyone help me?
Thank you so much guys!
Best regards!
Flávio Justino




--
View this message in context: http://lists.paparazziuav.org/Problem-during-instalation-of-paparazzi-arm-multilib-tp17953.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem during instalation of paparazzi-arm-multilib

flavio_just
Hi Felix!
Thank you so much, your help is always amazing!
I already installed paparazzi-arm-multilib.

However the big problem remains and I have no idea how to solve since my linux knowledge is pretty close to zero.
When I do the sudo make for my paparazzi source code, I get errors about ocaml:

cd data/maps; make PAPARAZZI_SRC=/home/quavist/MasterGNRExtMag PAPARAZZI_HOME=/home/quavist/MasterGNRExtMag
DOWNLOAD: google maps version code
if test ! -e conf/maps.xml; then cp conf/maps.xml.example conf/maps.xml; fi
cd sw/lib/ocaml; make PAPARAZZI_SRC=/home/quavist/MasterGNRExtMag PAPARAZZI_HOME=/home/quavist/MasterGNRExtMag
OC expr_lexer.ml
File "expr_lexer.ml", line 1:
Error: expr_parser.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
make[1]: *** [expr_lexer.cmo] Error 2
make: *** [lib] Error 2

Ok, it says it is from an older version of Ocaml. My problem is to know which version and how do I install it. My OS is
 Linux quavist-pc 3.19.0-56-generic #62~14.04.1-Ubuntu SMP Fri Mar 11 11:03:15 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Already tried do install Ubuntu 12.04 LTS 32-bit but still the error remained.

I know my source code version is about version 4 (don't know which exactly). This source code is from an academic research and is customized for a specific quadcopter, that's why is so important to build the code.

Do you have any idea for my problem?
Thank you so much again Felix!

Best regards,
Flavio Justino



2016-05-03 15:17 GMT+01:00 flixr [via Paparazzi UAV] <[hidden email]>:
Hi Flávio,

paparazzi-arm-multilib should still be available for precise, see https://launchpad.net/~paparazzi-uav/+archive/ubuntu/ppa/+packages

apt-cache policy paparazzi-arm-multilib
should print the version and repo where it was found (after apt-get update)

Cheers, Felix

On Tue, May 3, 2016 at 2:02 AM, flavio_just <[hidden email]> wrote:
Hi guys! I have an old source code that I need to build, it ffrom version 4
of Paparazzi. I have Ubuntu 12.04 LTS. I used the followd commands to
install paparazzi-arm-multilib:

sudo add-apt-repository ppa:paparazzi-uav/ppa
sudo apt-get update
sudo apt-get install paparazzi-dev paparazzi-arm-multilib

but I get the the message
E: Unable to locate package paparazzi-arm-multilib

I tried to make the source code without this installation but it gives some
Ocmpl errors.

Can anyone help me?
Thank you so much guys!
Best regards!
Flávio Justino




--
View this message in context: http://lists.paparazziuav.org/Problem-during-instalation-of-paparazzi-arm-multilib-tp17953.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



If you reply to this email, your message will be added to the discussion below:
http://lists.paparazziuav.org/Problem-during-instalation-of-paparazzi-arm-multilib-tp17953p17955.html
To start a new topic under paparazzi-devel, email [hidden email]
To unsubscribe from Paparazzi UAV, click here.
NAML



--
Flávio Justino

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem during instalation of paparazzi-arm-multilib

Simon Liebold
Hi Flavio,

Am 03.05.2016 um 23:55 schrieb flavio_just:
OC expr_lexer.ml
File "expr_lexer.ml", line 1:
Error: expr_parser.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
make[1]: *** [expr_lexer.cmo] Error 2
make: *** [lib] Error 2
OK, that is a bit guessing. But retry with
make clean && make
instead of just a
make
This should make sure that really everything gets rebuilt.

Simon

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Loading...