Parrot AR 2.0 Problem Telemetry Data

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Parrot AR 2.0 Problem Telemetry Data

Dimitar
k Hello,

I have tried the last days to autopilot my Parrot AR 2.0 but there is one problem arising between me and my goal: the telemetry data is not being transferred from the drone to the gcs application (It lasts forever without any change).

I use ubuntu 16.04.
The parrot software: 2.4.8.0.
Paparazzi release: v5.12_stable.
Airframe: ardrone2.xml
Telemetry: default_rotorcraft.xml

(Some of these settings differ from the tutorial https://www.youtube.com/watch?v=eojAPZvT1Ck&t=86s since the tutorial is with an older release of paparazzi)

It compiles and uploads without any problem, but the GCS does not initialize to the expected state. I have tried the solution proposed by https://lists.gnu.org/archive/html/paparazzi-devel/2016-08/msg00018.html but the result is the same. The file ap.elf again returns "var/aircrafts/ardrone2/ap/ap.elf: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), statically linked, for GNU/Linux 3.2.0 [..]".

I still get the error:

# ./ap.elf
FATAL: kernel too old
Segmentation fault

It would be an immense help if you have any ideas about this problem's solution.

Cheers!
Open Tracking
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Parrot AR 2.0 Problem Telemetry Data

Dimitar
Hello,

After reading some posts around the web I was able to solve the described
problem in my first post by following the instructions from
https://wiki.paparazziuav.org/wiki/AR_Drone_2 .

Thank you!
Dimitar



--
Sent from: http://lists.paparazziuav.org/paparazzi-devel-f3.html

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel