Ocaml Build Error in Ubuntu 16.04

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Ocaml Build Error in Ubuntu 16.04

rijesh
Hi all,

I just installed ubuntu 16.04 and upgraded all my packages. I then went on to install paparazzi using the one liner.
When doing so I ocaml version 4.02.3 was installed by default.

Got a few build errors and warnings when compiling ocaml.
I got the warning that strings was deprecated use bytes instead.

I got the error:
Error: This expression has type int32 but an expression was expected of type Gdk.native_window

I attempted to fix this by installing opam and running:
opam install -v lablgtk.2.16.0

This resulted in the recompilation of ocamlnet to fail.

I then went and downgraded to ocaml 4.01.0:
opam switch 4.01.1

Then I reinstalled any dependencies as required.

regards
Rijesh
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ocaml Build Error in Ubuntu 16.04

flixr
Administrator
Hi Rijesh,

this is due to a packaging bug of lablgtk 2.18 in Debian (it wrongly reports that it's 2.16).

See https://github.com/paparazzi/paparazzi/pull/1647 for details and the workaround I made.
That workaround was already merged in master, but I forgot to backport it to v5.8... applied it there as well now.

Cheers, Felix

On Fri, Jun 3, 2016 at 5:23 AM, rijesh <[hidden email]> wrote:
Hi all,

I just installed ubuntu 16.04 and upgraded all my packages. I then went on
to install paparazzi using the one liner.
When doing so I ocaml version 4.02.3 was installed by default.

Got a few build errors and warnings when compiling ocaml.
I got the warning that strings was deprecated use bytes instead.

I got the error:
Error: This expression has type int32 but an expression was expected of type
Gdk.native_window

I attempted to fix this by installing opam and running:
opam install -v lablgtk.2.16.0

This resulted in the recompilation of ocamlnet to fail.

I then went and downgraded to ocaml 4.01.0:
opam switch 4.01.1

Then I reinstalled any dependencies as required.

regards
Rijesh



--
View this message in context: http://lists.paparazziuav.org/Ocaml-Build-Error-in-Ubuntu-16-04-tp18038.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ocaml Build Error in Ubuntu 16.04

rijesh
Hi Felix,

I guess I didn't scroll far enough back on the master commit history.

In regards to the strings deprecated warning, is that something we want fix in all the ocaml code? Should I make an issue for it?

regards
Rijesh

On Fri, Jun 3, 2016 at 5:19 AM, Felix Ruess <[hidden email]> wrote:
Hi Rijesh,

this is due to a packaging bug of lablgtk 2.18 in Debian (it wrongly reports that it's 2.16).

See https://github.com/paparazzi/paparazzi/pull/1647 for details and the workaround I made.
That workaround was already merged in master, but I forgot to backport it to v5.8... applied it there as well now.

Cheers, Felix

On Fri, Jun 3, 2016 at 5:23 AM, rijesh <[hidden email]> wrote:
Hi all,

I just installed ubuntu 16.04 and upgraded all my packages. I then went on
to install paparazzi using the one liner.
When doing so I ocaml version 4.02.3 was installed by default.

Got a few build errors and warnings when compiling ocaml.
I got the warning that strings was deprecated use bytes instead.

I got the error:
Error: This expression has type int32 but an expression was expected of type
Gdk.native_window

I attempted to fix this by installing opam and running:
opam install -v lablgtk.2.16.0

This resulted in the recompilation of ocamlnet to fail.

I then went and downgraded to ocaml 4.01.0:
opam switch 4.01.1

Then I reinstalled any dependencies as required.

regards
Rijesh



--
View this message in context: http://lists.paparazziuav.org/Ocaml-Build-Error-in-Ubuntu-16-04-tp18038.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ocaml Build Error in Ubuntu 16.04

flixr
Administrator
Hi Rijesh,

regarding the warnings about deprecated String functions: We can't simply change it to Bytes to silence the warnings, as it would break compilation for everyone with OCaml < 4.02.0
I was looking into how we can use the camlp4 preprocessor to IFDEF around this... https://github.com/flixr/paparazzi/commit/007deabafe5fecc6ea7a1178566e69de4b804539

And yes, you can make an issue for it... should have done that a while ago already :-)

Cheers, Felix

On Fri, Jun 3, 2016 at 6:43 PM, Rijesh Augustine <[hidden email]> wrote:
Hi Felix,

I guess I didn't scroll far enough back on the master commit history.

In regards to the strings deprecated warning, is that something we want fix in all the ocaml code? Should I make an issue for it?

regards
Rijesh

On Fri, Jun 3, 2016 at 5:19 AM, Felix Ruess <[hidden email]> wrote:
Hi Rijesh,

this is due to a packaging bug of lablgtk 2.18 in Debian (it wrongly reports that it's 2.16).

See https://github.com/paparazzi/paparazzi/pull/1647 for details and the workaround I made.
That workaround was already merged in master, but I forgot to backport it to v5.8... applied it there as well now.

Cheers, Felix

On Fri, Jun 3, 2016 at 5:23 AM, rijesh <[hidden email]> wrote:
Hi all,

I just installed ubuntu 16.04 and upgraded all my packages. I then went on
to install paparazzi using the one liner.
When doing so I ocaml version 4.02.3 was installed by default.

Got a few build errors and warnings when compiling ocaml.
I got the warning that strings was deprecated use bytes instead.

I got the error:
Error: This expression has type int32 but an expression was expected of type
Gdk.native_window

I attempted to fix this by installing opam and running:
opam install -v lablgtk.2.16.0

This resulted in the recompilation of ocamlnet to fail.

I then went and downgraded to ocaml 4.01.0:
opam switch 4.01.1

Then I reinstalled any dependencies as required.

regards
Rijesh



--
View this message in context: http://lists.paparazziuav.org/Ocaml-Build-Error-in-Ubuntu-16-04-tp18038.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Loading...