Mac OS installation problem

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Mac OS installation problem

Nicolas Quendez

Hi everyone,

I am a newcomer in this list, I plan to use paparazzi autopilot. I knew a little bit the project because I had the luck to assist to the very beginning of Paparazzi a long time ago, when Antoine and Pascal just started it. The work done until now is really amazing ! In my side, I am more an airframe designer than computer expert...


So I face the first problem installing Paparazzi-Tools into my mac (snow-leopard on it). Problems seems begin with ocaml-pcre install :

--->  Extracting ocaml-pcre
--->  Configuring ocaml-pcre
--->  Building ocaml-pcre
Error: org.macports.build for port ocaml-pcre returned: command execution failed
Error: Failed to install ocaml-pcre
Please see the log file for port ocaml-pcre for details:
   /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_ocaml-pcre/ocaml-pcre/main.log
Error: The following dependencies were not installed: ivy-ocaml ocaml-ocamlnet ocaml-pcre jsbsim tcl lablgtk2 libglade2 libgnomecanvas libart_lgpl libgnomeui gconf dbus-glib dbus gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils iso-codes libxslt py27-libxml2 rarian orbit2 libidl policykit libbonoboui desktop-file-utils libbonobo libgnome gnome-vfs gnome-mime-data libcanberra gstreamer1 bison flex gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto dbus-python27 py27-gobject libvorbis libogg libgnome-keyring libgcrypt libgpg-error xorg-libice xorg-libsm libcmsis libmpc mpfr libftdi0 libusb-compat libusb libopencm3 libsdl libstm32 ocaml-gsl gawk readline gsl ocamlsdl lablgl libsdl_image libsdl_mixer flac libmikmod smpeg libsdl_ttf openocd py27-pyusb-devel py27-scipy SuiteSparse gcc47 cctools cctools-headers llvm-3.3 llvm_select cloog isl gcc_select ld64 libgcc ppl glpk py27-nose nosetests_select py27-setuptools py27-numpy fftw-3 swig-python swig py27-yaml libyaml py27-cython cython_select tkdiff tk wget gnutls libtasn1 nettle xml-light
To report a bug, follow the instructions in the guide:
   http://guide.macports.org/#project.tickets
Error: Processing of port paparazzi-tools failed



If somebody have an idea to go on...

Thanks in advance
Best regards
Nicolas
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS installation problem

Stephen Dwyer
Hello Nicolas,

So the ocaml dependencies don't seem to be handled very well in MacPorts for some reason. I used to have a problem with ocaml-pcre, and now I have problems with libgnomecanvas. My best suggestion is to take your list of dependencies that were not installed and try to manually install all except some of the key ocaml ports. You can just copy and paste that list to a text editor, remove anything with ocaml in it, and copy it back trying "sudo port install <space separated list of ports>". If any ports continue to fail, try to remove them slowly until things install. Then you can try installing paparazzi-tools again. You may have to try this a few times. I realize this method is very hackish, but there isn't a good way to be able to specify more details about the order in which ports are installed in macports, without using a custom script.

Also, before you try installing more, clean the failed port: "sudo port clean ocaml-pcre"

Hopefully that helps. Post to the list if you have more problems. Also, just a reminder, the gcc-arm-embedded that I have set up on the default port isn't really meant for Snow Leopard. In particular, gdb is compiled with python 2.7 support but that framework isn't default on Snow Leopard. You can either compile from source without python support enabled, or try installing the python 2.7 framework. If you don't plan to do JTAG/SWD debugging or programming on the autopilots, then you don't need to worry about it.

Thanks,
-Stephen Dwyer




On Fri, Aug 23, 2013 at 5:42 AM, Nicolas Quendez <[hidden email]> wrote:

Hi everyone,

I am a newcomer in this list, I plan to use paparazzi autopilot. I knew a little bit the project because I had the luck to assist to the very beginning of Paparazzi a long time ago, when Antoine and Pascal just started it. The work done until now is really amazing ! In my side, I am more an airframe designer than computer expert...


So I face the first problem installing Paparazzi-Tools into my mac (snow-leopard on it). Problems seems begin with ocaml-pcre install :

--->  Extracting ocaml-pcre
--->  Configuring ocaml-pcre
--->  Building ocaml-pcre
Error: org.macports.build for port ocaml-pcre returned: command execution failed
Error: Failed to install ocaml-pcre
Please see the log file for port ocaml-pcre for details:
   /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_ocaml-pcre/ocaml-pcre/main.log
Error: The following dependencies were not installed: ivy-ocaml ocaml-ocamlnet ocaml-pcre jsbsim tcl lablgtk2 libglade2 libgnomecanvas libart_lgpl libgnomeui gconf dbus-glib dbus gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils iso-codes libxslt py27-libxml2 rarian orbit2 libidl policykit libbonoboui desktop-file-utils libbonobo libgnome gnome-vfs gnome-mime-data libcanberra gstreamer1 bison flex gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto dbus-python27 py27-gobject libvorbis libogg libgnome-keyring libgcrypt libgpg-error xorg-libice xorg-libsm libcmsis libmpc mpfr libftdi0 libusb-compat libusb libopencm3 libsdl libstm32 ocaml-gsl gawk readline gsl ocamlsdl lablgl libsdl_image libsdl_mixer flac libmikmod smpeg libsdl_ttf openocd py27-pyusb-devel py27-scipy SuiteSparse gcc47 cctools cctools-headers llvm-3.3 llvm_select cloog isl gcc_select ld64 libgcc ppl!
  glpk py27-nose nosetests_select py27-setuptools py27-numpy fftw-3 swig-python swig py27-yaml libyaml py27-cython cython_select tkdiff tk wget gnutls libtasn1 nettle xml-light
To report a bug, follow the instructions in the guide:
   http://guide.macports.org/#project.tickets
Error: Processing of port paparazzi-tools failed



If somebody have an idea to go on...

Thanks in advance
Best regards
Nicolas
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS installation problem

michael matkov
In reply to this post by Nicolas Quendez
Hello Nicolas,

So the ocaml dependencies don't seem to be handled very well in MacPorts for some reason. I used to have a problem with ocaml-pcre, and now I have problems with libgnomecanvas. My best suggestion is to take your list of dependencies that were not installed and try to manually install all except some of the key ocaml ports. You can just copy and paste that list to a text editor, remove anything with ocaml in it, and copy it back trying "sudo port install <space separated list of ports>". If any ports continue to fail, try to remove them slowly until things install. Then you can try installing paparazzi-tools again. You may have to try this a few times. I realize this method is very hackish, but there isn't a good way to be able to specify more details about the order in which ports are installed in macports, without using a custom script.

Also, before you try installing more, clean the failed port: "sudo port clean ocaml-pcre"

Hopefully that helps. Post to the list if you have more problems. Also, just a reminder, the gcc-arm-embedded that I have set up on the default port isn't really meant for Snow Leopard. In particular, gdb is compiled with python 2.7 support but that framework isn't default on Snow Leopard. You can either compile from source without python support enabled, or try installing the python 2.7 framework. If you don't plan to do JTAG/SWD debugging or programming on the autopilots, then you don't need to worry about it.

Thanks,
-Stephen Dwyer




On Fri, Aug 23, 2013 at 5:42 AM, Nicolas Quendez <[hidden email]> wrote:

Hi everyone,

I am a newcomer in this list, I plan to use paparazzi autopilot. I knew a little bit the project because I had the luck to assist to the very beginning of Paparazzi a long time ago, when Antoine and Pascal just started it. The work done until now is really amazing ! In my side, I am more an airframe designer than computer expert...


So I face the first problem installing Paparazzi-Tools into my mac (snow-leopard on it). Problems seems begin with ocaml-pcre install :

--->  Extracting ocaml-pcre
--->  Configuring ocaml-pcre
--->  Building ocaml-pcre
Error: org.macports.build for port ocaml-pcre returned: command execution failed
Error: Failed to install ocaml-pcre
Please see the log file for port ocaml-pcre for details:
   /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_ocaml-pcre/ocaml-pcre/main.log
Error: The following dependencies were not installed: ivy-ocaml ocaml-ocamlnet ocaml-pcre jsbsim tcl lablgtk2 libglade2 libgnomecanvas libart_lgpl libgnomeui gconf dbus-glib dbus gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils iso-codes libxslt py27-libxml2 rarian orbit2 libidl policykit libbonoboui desktop-file-utils libbonobo libgnome gnome-vfs gnome-mime-data libcanberra gstreamer1 bison flex gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto dbus-python27 py27-gobject libvorbis libogg libgnome-keyring libgcrypt libgpg-error xorg-libice xorg-libsm libcmsis libmpc mpfr libftdi0 libusb-compat libusb libopencm3 libsdl libstm32 ocaml-gsl gawk readline gsl ocamlsdl lablgl libsdl_image libsdl_mixer flac libmikmod smpeg libsdl_ttf openocd py27-pyusb-devel py27-scipy SuiteSparse gcc47 cctools cctools-headers llvm-3.3 llvm_select cloog isl gcc_select ld64 libgcc ppl!
  glpk py27-nose nosetests_select py27-setuptools py27-numpy fftw-3 swig-python swig py27-yaml libyaml py27-cython cython_select tkdiff tk wget gnutls libtasn1 nettle xml-light
To report a bug, follow the instructions in the guide:
   http://guide.macports.org/#project.tickets
Error: Processing of port paparazzi-tools failed



If somebody have an idea to go on...

Thanks in advance
Best regards
Nicolas
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Mac OS installation problem

Nicolas Quendez
In reply to this post by Stephen Dwyer

Thanks a lot Stephen, 

Following your advices, for now I was not successful installing the following dependencies at the end, whatever the order : 
gnome-vfs 
ocaml-ocamlnet
ocaml-pcre 
gconf 
libgnome


So I will clean again everything and try again...
Nicolas


Le 23 août 2013 à 17:14, Stephen Dwyer a écrit :

Hello Nicolas,

So the ocaml dependencies don't seem to be handled very well in MacPorts for some reason. I used to have a problem with ocaml-pcre, and now I have problems with libgnomecanvas. My best suggestion is to take your list of dependencies that were not installed and try to manually install all except some of the key ocaml ports. You can just copy and paste that list to a text editor, remove anything with ocaml in it, and copy it back trying "sudo port install <space separated list of ports>". If any ports continue to fail, try to remove them slowly until things install. Then you can try installing paparazzi-tools again. You may have to try this a few times. I realize this method is very hackish, but there isn't a good way to be able to specify more details about the order in which ports are installed in macports, without using a custom script.

Also, before you try installing more, clean the failed port: "sudo port clean ocaml-pcre"

Hopefully that helps. Post to the list if you have more problems. Also, just a reminder, the gcc-arm-embedded that I have set up on the default port isn't really meant for Snow Leopard. In particular, gdb is compiled with python 2.7 support but that framework isn't default on Snow Leopard. You can either compile from source without python support enabled, or try installing the python 2.7 framework. If you don't plan to do JTAG/SWD debugging or programming on the autopilots, then you don't need to worry about it.

Thanks,
-Stephen Dwyer




On Fri, Aug 23, 2013 at 5:42 AM, Nicolas Quendez <[hidden email]> wrote:

Hi everyone,

I am a newcomer in this list, I plan to use paparazzi autopilot. I knew a little bit the project because I had the luck to assist to the very beginning of Paparazzi a long time ago, when Antoine and Pascal just started it. The work done until now is really amazing ! In my side, I am more an airframe designer than computer expert...


So I face the first problem installing Paparazzi-Tools into my mac (snow-leopard on it). Problems seems begin with ocaml-pcre install :

--->  Extracting ocaml-pcre
--->  Configuring ocaml-pcre
--->  Building ocaml-pcre
Error: org.macports.build for port ocaml-pcre returned: command execution failed
Error: Failed to install ocaml-pcre
Please see the log file for port ocaml-pcre for details:
   /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_ocaml-pcre/ocaml-pcre/main.log
Error: The following dependencies were not installed: ivy-ocaml ocaml-ocamlnet ocaml-pcre jsbsim tcl lablgtk2 libglade2 libgnomecanvas libart_lgpl libgnomeui gconf dbus-glib dbus gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils iso-codes libxslt py27-libxml2 rarian orbit2 libidl policykit libbonoboui desktop-file-utils libbonobo libgnome gnome-vfs gnome-mime-data libcanberra gstreamer1 bison flex gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto dbus-python27 py27-gobject libvorbis libogg libgnome-keyring libgcrypt libgpg-error xorg-libice xorg-libsm libcmsis libmpc mpfr libftdi0 libusb-compat libusb libopencm3 libsdl libstm32 ocaml-gsl gawk readline gsl ocamlsdl lablgl libsdl_image libsdl_mixer flac libmikmod smpeg libsdl_ttf openocd py27-pyusb-devel py27-scipy SuiteSparse gcc47 cctools cctools-headers llvm-3.3 llvm_select cloog isl gcc_select ld64 libgcc ppl!
  glpk py27-nose nosetests_select py27-setuptools py27-numpy fftw-3 swig-python swig py27-yaml libyaml py27-cython cython_select tkdiff tk wget gnutls libtasn1 nettle xml-light
To report a bug, follow the instructions in the guide:
   http://guide.macports.org/#project.tickets
Error: Processing of port paparazzi-tools failed



If somebody have an idea to go on...

Thanks in advance
Best regards
Nicolas
_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel