Issue about the installation of paparazzi for my OSX

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue about the installation of paparazzi for my OSX

kevindsp
Hi,all.
    I wanna install Paparazzi to my osx(10.14.4).However,it encounters some
errors while I follow the wiki's instructions step by step.What's wrong?And
how could I fix the problem?Thank you!

   


here is the input and The out put of the issue:



==> Installing ivy-c from paparazzi/paparazzi
==> Cloning https://github.com/esden/ivy-c.git
Updating /Users/Library/Caches/Homebrew/ivy-c--git
==> Checking out branch osx-tcl
Already on 'osx-tcl'
Your branch is up to date with 'origin/osx-tcl'.
HEAD is now at 9721c37 Added libtclivy compilation on OS X.
==> make -C src -f Makefile.osx PREFIX=/usr/local/Cellar/ivy-c/3.15 install
Last 15 lines from /Users/kevin/Library/Logs/Homebrew/ivy-c/01.make:
  ^~~~~~
  pcrecpp::string
/usr/local/Cellar/pcre/8.43/include/pcre_stringpiece.h:59:12: note:
'pcrecpp::string' declared here
using std::string;
           ^
ivythroughput.cpp:621:5: error: unknown type name 'string'; did you mean
'pcrecpp::string'?
    string reg = *iter2;
    ^~~~~~
    pcrecpp::string
/usr/local/Cellar/pcre/8.43/include/pcre_stringpiece.h:59:12: note:
'pcrecpp::string' declared here
using std::string;
           ^
8 errors generated.
make[1]: *** [ivythroughput.o] Error 1
make: *** [tools] Error 2

If reporting this issue please do so at (not Homebrew/brew or
Homebrew/core):
  https://github.com/paparazzi/homebrew-paparazzi/issues

These open issues may also help:
'brew install ivy-c jsbsim' error
https://github.com/paparazzi/homebrew-paparazzi/issues/2
Issue installing ivy-c and jbsim on OSX 10.13
https://github.com/paparazzi/homebrew-paparazzi/issues/4



--
Sent from: http://lists.paparazziuav.org/paparazzi-devel-f3.html

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue about the installation of paparazzi for my OSX

Yannick Jestin


> On 23 May 2019, at 18:15, kevindsp <[hidden email]> wrote:
>
> Hi,all.
>    I wanna install Paparazzi to my osx(10.14.4).However,it encounters some
> errors while I follow the wiki's instructions step by step.What's wrong?And
> how could I fix the problem?Thank you!

  I think that adding the following line in ivythroughput.cpp does the trick:

        using namespace std;


  Y.


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: Issue about the installation of paparazzi for my OSX

kevindsp
Than you!
        However,there is no such a file"ivythroughput.cpp"in the computer.

        I think that if it is the temperate file while the brew is
installing ivy-c?



--
Sent from: http://lists.paparazziuav.org/paparazzi-devel-f3.html

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel