I2C driver problem.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

I2C driver problem.

icemanx
Hello,

I'm trying to implement l3dd20h gyro. I'm using stm32f4 discovery board.When I look i2c2 SCL and SDA lines with logic analyzer, I only see clock is working as expected but here is no data at SDA pin. Here is my configuration file:

my altimu10 makefile: imu_altimu10.makefile

I'm just using i2c_submit fuction to read WHO_AM_I register of the chip.

If you can assist me, I'll be very glad.

Thanks for help!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I2C driver problem.

flixr
Administrator
Hi,

so you implemented sw/airborne/peripherals/l3gd20_i2c.[ch] analog to the SPI implementation?
Can you share those files and the imu implementation? A bit hard to check anything without seeing the new code..
If you have it on github, a link to it is easiest...

Also which i2c bus are you using?

Cheers, Felix

On Sat, Jun 11, 2016 at 11:13 AM, icemanx <[hidden email]> wrote:
Hello,

I'm trying to implement l3dd20h gyro. I'm using stm32f4 discovery board.When
I look i2c2 SCL and SDA lines with logic analyzer, I only see clock is
working as expected but here is no data at SDA pin. Here is my configuration
file:

my altimu10 makefile:  imu_altimu10.makefile
<http://lists.paparazziuav.org/file/n18059/imu_altimu10.makefile>

I'm just using i2c_submit fuction to read WHO_AM_I register of the chip.

If you can assist me, I'll be very glad.

Thanks for help!



--
View this message in context: http://lists.paparazziuav.org/I2C-driver-problem-tp18059.html
Sent from the paparazzi-devel mailing list archive at Nabble.com.

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel


_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I2C driver problem.

icemanx
Hey,

Sorry for the late reply, I just made mistake in the code. So they are all OK. As soon as finishing the tests, I'll upload them to the github. I'm using altimu-10. Barometer is now work-in-progress.

Thank you for your help!
Loading...