How could I install the obsolete port git-core?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

How could I install the obsolete port git-core?

心如烛光
Hi,all!
    I get an error while I reinstall paparazzi with macport.The git-core has been made obsolete by the macport.
here is the return:
--->  Configuring git-core
Error: git-core has been made obsolete by the port git. Please install git instead.
Error: org.macports.configure for port git-core returned: obsolete port
Error: Failed to install git-core

And I have tried to install git with the command "sudo port install git".However,even after that I still get the very same error while it is installing paparazzi-tools.What should I do to avoid the problem I met?How could I install paparazzi-tools successfully?Thank's a lot!

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: How could I install the obsolete port git-core?

Stephen Dwyer
Hello,

It appears they have changed the port name very recently. We will need to update the paparazzi-tools port to depend on git instead of git-core.

As a temporary fix, you can manually edit the paparazzi-tools port file to install git instead of git core.

Clean the halted install:
$ sudo port clean paparazzi-tools

Edit the port file:
$ sudo port edit paparazzi-tools

Change this line:
    port:git-core \
to this:
    port:git \
and save the file.

Then try to install the port again:
$ sudo port install paparazzi-tools

If you do this, the next time you do port selfupdate, it will reset the port file back to the original, so you would have to edit it again (I think).

Note I have not actually tested this, but it should work (been a while since I was playing around with macports though). If you want to update the port in paparazzi-portability-support and submit a pull request, awesome! Let me know if this doesn't work.

Thanks,
-Stephen Dwyer



On Thu, Jun 12, 2014 at 9:38 AM, 心如烛光 <[hidden email]> wrote:
Hi,all!
    I get an error while I reinstall paparazzi with macport.The git-core has been made obsolete by the macport.
here is the return:
--->  Configuring git-core
Error: git-core has been made obsolete by the port git. Please install git instead.
Error: org.macports.configure for port git-core returned: obsolete port
Error: Failed to install git-core

And I have tried to install git with the command "sudo port install git".However,even after that I still get the very same error while it is installing paparazzi-tools.What should I do to avoid the problem I met?How could I install paparazzi-tools successfully?Thank's a lot!

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel