GPS status NOFIX Problem AR DRONE 2.0 uBlox NEO-6M

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GPS status NOFIX Problem AR DRONE 2.0 uBlox NEO-6M

Dimitar
Hello,

we are trying since couple of weeks to fix the following problem:

we get a NOFIX status for the GPS each time we run the program. All other
telemetry data like gyro is present, but the GPS is sending only zeros as
depicted in the uploaded picture.

We have reinstalled the Paparazzi software, we have set all options like
advised  in http://wiki.paparazziuav.org/wiki/Sensors/GPS for the uBlox
LEA-6H GPS. The GPS is set to baud rate 38400 and is able to acquire signal
from the uCenter desktop application.

Thank You in advance!!!

<http://lists.paparazziuav.org/file/t1135/Problem_NOFIX.png>



--
Sent from: http://lists.paparazziuav.org/paparazzi-devel-f3.html

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: GPS status NOFIX Problem AR DRONE 2.0 uBlox NEO-6M

Dimitar
It is fixed now thanks to the suggestion of Gautier. Thank you Gautier!!!

The problem was in the default UART baudrate from 57600in
https://github.com/paparazzi/paparazzi/blob/master/conf/boards/ardrone2.makefile#L33
. We changed it to the baudrate configured in our uBlox NEO-6M and
everything runs perfect now.





--
Sent from: http://lists.paparazziuav.org/paparazzi-devel-f3.html

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel