GPS behavour after renaming subsystems to modules.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

GPS behavour after renaming subsystems to modules.

Helge Walle
Hi,
I am testing my airframe files after renaming subsystems to modules, and I get some problems with my GPS, which is a Navilock NL-552ettl. The GPS reports a fix in GCS, but the aircraft does not show up on the screen. The waypoints disappear from the screen one after the other after the fix is obtained.
In Paparazzi center, I repeatedly I get the message Invalid_argument("Latlong.of_utm").

When I build the aircraft with GPS as subsystem, I get this on the compiling list:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o

When I build the aircraft with GPS named as module, the order of the two lines are reversed and I get this:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o

With GPS as subsystem everything works normally.

I am on version v5.8.1_stable-4-gbc4bff1.
Below is the firmware part of my airframe file.

Thans for any help,
Helge.


 <firmware name="fixedwing">
    <target name="ap"                                board="twog_1.0">
      <configure name="PERIODIC_FREQUENCY"           value="120"/>
      <configure name="AHRS_PROPAGATE_FREQUENCY"     value="100"/>
      <configure name="AHRS_CORRECT_FREQUENCY"       value="100"/>
      <define name="AHRS_TRIGGERED_ATTITUDE_LOOP" />
      <configure name="AHRS_ALIGNER_LED"             value="3"/>
      <configure name="CPU_LED"                      value="3"/>
      <define name="USE_I2C0"/>

      <define name="PERIOD_NAVIGATION_0"/><!-- stop NAVIGATION msg in main_ap.c -->
    </target>

    <target name="sim"                          board="pc"/>

    <!-- Global firmware defines -->
    <define name="LOITER_TRIM"/>
    <define name="AGR_CLIMB"/>
    <define name="WIND_INFO"/>
    <define name="WIND_INFO_RET"/>
    <define name="STRONG_WIND"/>

    <!-- Sensors -->
    <!-- <module name="gps"           type="ublox"/> -->
    <subsystem name="gps"           type="ublox"/>

    <module name="imu"           type="sen10121">
       <define name="IMU_SEN10121_ID" value="28"/>
    </module>
    <module name="ahrs" type="int_cmpl_quat">
       <configure name="USE_MAGNETOMETER" value="0"/>
       <define name="AHRS_USE_GPS_HEADING" value="1"/>
       <define name="AHRS_GRAVITY_UPDATE_COORDINATED_TURN"/>
    </module>

    <!-- Radio Control -->
    <module name="radio_control" type="ppm"/>

    <!-- Communication -->
    <module name="telemetry"     type="transparent"/>

    <!-- Navigation -->
    <module name="navigation"/>

    <!-- Actuators -->
    <module name="control"/>

    <module name="ins" type="alt_float"/>

    <module name="baro_ms5611_i2c_twin.xml">
      <define name="MS5611_I2C_DEV_1" value="i2c0"/>
      <define name="MS5611_I2C_DEV_2" value="i2c0"/>
      <define name="MS5611_SLAVE_ADDR_1" value="0xEE"/>
      <define name="MS5611_SLAVE_ADDR_2" value="0xEC"/>
      <define name="MS5611_KALMAN_Q" value=".5"/>
      <define name="MS5611_KALMAN_R" value="6."/>
      <define name="MS5611_AIRSPEED_SCALE_FACTOR" value="2.5"/>
      <define name="SENSOR_SYNC_SEND"/>
    </module>

    <module name="air_data.xml"/>
 </firmware>

 <firmware name="setup">
    <target name="tunnel"          board="twog_1.0"/>
    <target name="setup_actuators"   board="twog_1.0"/>
 </firmware>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: GPS behavour after renaming subsystems to modules.

flixr
Administrator
Hi Helge,

that sounds very strange, since if no module of that name is available it will just use the subsystem as before.
You can also see this if you look at the generated $PAPARAZZI_HOME/var/aircrafts/<acname>/Makefile.ac

Don't have any idea what the reason could be for different behavior right now...

Felix

On Mon, Jun 20, 2016 at 2:00 PM, Helge Walle <[hidden email]> wrote:
Hi,
I am testing my airframe files after renaming subsystems to modules, and I get some problems with my GPS, which is a Navilock NL-552ettl. The GPS reports a fix in GCS, but the aircraft does not show up on the screen. The waypoints disappear from the screen one after the other after the fix is obtained.
In Paparazzi center, I repeatedly I get the message Invalid_argument("Latlong.of_utm").

When I build the aircraft with GPS as subsystem, I get this on the compiling list:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o

When I build the aircraft with GPS named as module, the order of the two lines are reversed and I get this:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o

With GPS as subsystem everything works normally.

I am on version v5.8.1_stable-4-gbc4bff1.
Below is the firmware part of my airframe file.

Thans for any help,
Helge.


 <firmware name="fixedwing">
    <target name="ap"                                board="twog_1.0">
      <configure name="PERIODIC_FREQUENCY"           value="120"/>
      <configure name="AHRS_PROPAGATE_FREQUENCY"     value="100"/>
      <configure name="AHRS_CORRECT_FREQUENCY"       value="100"/>
      <define name="AHRS_TRIGGERED_ATTITUDE_LOOP" />
      <configure name="AHRS_ALIGNER_LED"             value="3"/>
      <configure name="CPU_LED"                      value="3"/>
      <define name="USE_I2C0"/>

      <define name="PERIOD_NAVIGATION_0"/><!-- stop NAVIGATION msg in main_ap.c -->
    </target>

    <target name="sim"                          board="pc"/>

    <!-- Global firmware defines -->
    <define name="LOITER_TRIM"/>
    <define name="AGR_CLIMB"/>
    <define name="WIND_INFO"/>
    <define name="WIND_INFO_RET"/>
    <define name="STRONG_WIND"/>

    <!-- Sensors -->
    <!-- <module name="gps"           type="ublox"/> -->
    <subsystem name="gps"           type="ublox"/>

    <module name="imu"           type="sen10121">
       <define name="IMU_SEN10121_ID" value="28"/>
    </module>
    <module name="ahrs" type="int_cmpl_quat">
       <configure name="USE_MAGNETOMETER" value="0"/>
       <define name="AHRS_USE_GPS_HEADING" value="1"/>
       <define name="AHRS_GRAVITY_UPDATE_COORDINATED_TURN"/>
    </module>

    <!-- Radio Control -->
    <module name="radio_control" type="ppm"/>

    <!-- Communication -->
    <module name="telemetry"     type="transparent"/>

    <!-- Navigation -->
    <module name="navigation"/>

    <!-- Actuators -->
    <module name="control"/>

    <module name="ins" type="alt_float"/>

    <module name="baro_ms5611_i2c_twin.xml">
      <define name="MS5611_I2C_DEV_1" value="i2c0"/>
      <define name="MS5611_I2C_DEV_2" value="i2c0"/>
      <define name="MS5611_SLAVE_ADDR_1" value="0xEE"/>
      <define name="MS5611_SLAVE_ADDR_2" value="0xEC"/>
      <define name="MS5611_KALMAN_Q" value=".5"/>
      <define name="MS5611_KALMAN_R" value="6."/>
      <define name="MS5611_AIRSPEED_SCALE_FACTOR" value="2.5"/>
      <define name="SENSOR_SYNC_SEND"/>
    </module>

    <module name="air_data.xml"/>
 </firmware>

 <firmware name="setup">
    <target name="tunnel"          board="twog_1.0"/>
    <target name="setup_actuators"   board="twog_1.0"/>
 </firmware>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: GPS behavour after renaming subsystems to modules.

Helge Walle
Thank you for your response Felix,

I just made two builds where the difference is only "subsystem" or "module" in the declaration in the gps line in the airframe file. The two makefiles (attached) are renamed to tell one from the other.

The files are a bit different. It seems the "module" makefile contains the gps build lines, while the "subsystem" makefile refers to the conf/firmwares/subsystems/fixedwing/gps_ublox.makefile. The order of the files gps_ubx.c and gps.c seems to appear different in the two cases. I don't know if this is relevant to the trouble I experience.

I am a bit over my head in this, maybe I need to spend some time looking more deeply into this myself. I have added a couple of my own modules for imu and baro, but no gps stuff.

Thanks, Helge.



2016-06-20 17:08 GMT+02:00 Felix Ruess <[hidden email]>:
Hi Helge,

that sounds very strange, since if no module of that name is available it will just use the subsystem as before.
You can also see this if you look at the generated $PAPARAZZI_HOME/var/aircrafts/<acname>/Makefile.ac

Don't have any idea what the reason could be for different behavior right now...

Felix

On Mon, Jun 20, 2016 at 2:00 PM, Helge Walle <[hidden email]> wrote:
Hi,
I am testing my airframe files after renaming subsystems to modules, and I get some problems with my GPS, which is a Navilock NL-552ettl. The GPS reports a fix in GCS, but the aircraft does not show up on the screen. The waypoints disappear from the screen one after the other after the fix is obtained.
In Paparazzi center, I repeatedly I get the message Invalid_argument("Latlong.of_utm").

When I build the aircraft with GPS as subsystem, I get this on the compiling list:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o

When I build the aircraft with GPS named as module, the order of the two lines are reversed and I get this:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o

With GPS as subsystem everything works normally.

I am on version v5.8.1_stable-4-gbc4bff1.
Below is the firmware part of my airframe file.

Thans for any help,
Helge.


 <firmware name="fixedwing">
    <target name="ap"                                board="twog_1.0">
      <configure name="PERIODIC_FREQUENCY"           value="120"/>
      <configure name="AHRS_PROPAGATE_FREQUENCY"     value="100"/>
      <configure name="AHRS_CORRECT_FREQUENCY"       value="100"/>
      <define name="AHRS_TRIGGERED_ATTITUDE_LOOP" />
      <configure name="AHRS_ALIGNER_LED"             value="3"/>
      <configure name="CPU_LED"                      value="3"/>
      <define name="USE_I2C0"/>

      <define name="PERIOD_NAVIGATION_0"/><!-- stop NAVIGATION msg in main_ap.c -->
    </target>

    <target name="sim"                          board="pc"/>

    <!-- Global firmware defines -->
    <define name="LOITER_TRIM"/>
    <define name="AGR_CLIMB"/>
    <define name="WIND_INFO"/>
    <define name="WIND_INFO_RET"/>
    <define name="STRONG_WIND"/>

    <!-- Sensors -->
    <!-- <module name="gps"           type="ublox"/> -->
    <subsystem name="gps"           type="ublox"/>

    <module name="imu"           type="sen10121">
       <define name="IMU_SEN10121_ID" value="28"/>
    </module>
    <module name="ahrs" type="int_cmpl_quat">
       <configure name="USE_MAGNETOMETER" value="0"/>
       <define name="AHRS_USE_GPS_HEADING" value="1"/>
       <define name="AHRS_GRAVITY_UPDATE_COORDINATED_TURN"/>
    </module>

    <!-- Radio Control -->
    <module name="radio_control" type="ppm"/>

    <!-- Communication -->
    <module name="telemetry"     type="transparent"/>

    <!-- Navigation -->
    <module name="navigation"/>

    <!-- Actuators -->
    <module name="control"/>

    <module name="ins" type="alt_float"/>

    <module name="baro_ms5611_i2c_twin.xml">
      <define name="MS5611_I2C_DEV_1" value="i2c0"/>
      <define name="MS5611_I2C_DEV_2" value="i2c0"/>
      <define name="MS5611_SLAVE_ADDR_1" value="0xEE"/>
      <define name="MS5611_SLAVE_ADDR_2" value="0xEC"/>
      <define name="MS5611_KALMAN_Q" value=".5"/>
      <define name="MS5611_KALMAN_R" value="6."/>
      <define name="MS5611_AIRSPEED_SCALE_FACTOR" value="2.5"/>
      <define name="SENSOR_SYNC_SEND"/>
    </module>

    <module name="air_data.xml"/>
 </firmware>

 <firmware name="setup">
    <target name="tunnel"          board="twog_1.0"/>
    <target name="setup_actuators"   board="twog_1.0"/>
 </firmware>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel

Makefile_module.ac (9K) Download Attachment
Makefile_subsystem.ac (9K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: GPS behavour after renaming subsystems to modules.

Helge Walle
Hi again, just an update.

I opened the file conf/modules/gps_ublox.xml and uncommented this line:
<define name="GPS_USE_LATLONG"/>

and then I got the ac and all waypoints on the screen/map ok.
Is this how it should be, or could it be something else in my setup?

Thanks, Helge.


2016-06-20 18:48 GMT+02:00 Helge Walle <[hidden email]>:
Thank you for your response Felix,

I just made two builds where the difference is only "subsystem" or "module" in the declaration in the gps line in the airframe file. The two makefiles (attached) are renamed to tell one from the other.

The files are a bit different. It seems the "module" makefile contains the gps build lines, while the "subsystem" makefile refers to the conf/firmwares/subsystems/fixedwing/gps_ublox.makefile. The order of the files gps_ubx.c and gps.c seems to appear different in the two cases. I don't know if this is relevant to the trouble I experience.

I am a bit over my head in this, maybe I need to spend some time looking more deeply into this myself. I have added a couple of my own modules for imu and baro, but no gps stuff.

Thanks, Helge.



2016-06-20 17:08 GMT+02:00 Felix Ruess <[hidden email]>:
Hi Helge,

that sounds very strange, since if no module of that name is available it will just use the subsystem as before.
You can also see this if you look at the generated $PAPARAZZI_HOME/var/aircrafts/<acname>/Makefile.ac

Don't have any idea what the reason could be for different behavior right now...

Felix

On Mon, Jun 20, 2016 at 2:00 PM, Helge Walle <[hidden email]> wrote:
Hi,
I am testing my airframe files after renaming subsystems to modules, and I get some problems with my GPS, which is a Navilock NL-552ettl. The GPS reports a fix in GCS, but the aircraft does not show up on the screen. The waypoints disappear from the screen one after the other after the fix is obtained.
In Paparazzi center, I repeatedly I get the message Invalid_argument("Latlong.of_utm").

When I build the aircraft with GPS as subsystem, I get this on the compiling list:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o

When I build the aircraft with GPS named as module, the order of the two lines are reversed and I get this:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o

With GPS as subsystem everything works normally.

I am on version v5.8.1_stable-4-gbc4bff1.
Below is the firmware part of my airframe file.

Thans for any help,
Helge.


 <firmware name="fixedwing">
    <target name="ap"                                board="twog_1.0">
      <configure name="PERIODIC_FREQUENCY"           value="120"/>
      <configure name="AHRS_PROPAGATE_FREQUENCY"     value="100"/>
      <configure name="AHRS_CORRECT_FREQUENCY"       value="100"/>
      <define name="AHRS_TRIGGERED_ATTITUDE_LOOP" />
      <configure name="AHRS_ALIGNER_LED"             value="3"/>
      <configure name="CPU_LED"                      value="3"/>
      <define name="USE_I2C0"/>

      <define name="PERIOD_NAVIGATION_0"/><!-- stop NAVIGATION msg in main_ap.c -->
    </target>

    <target name="sim"                          board="pc"/>

    <!-- Global firmware defines -->
    <define name="LOITER_TRIM"/>
    <define name="AGR_CLIMB"/>
    <define name="WIND_INFO"/>
    <define name="WIND_INFO_RET"/>
    <define name="STRONG_WIND"/>

    <!-- Sensors -->
    <!-- <module name="gps"           type="ublox"/> -->
    <subsystem name="gps"           type="ublox"/>

    <module name="imu"           type="sen10121">
       <define name="IMU_SEN10121_ID" value="28"/>
    </module>
    <module name="ahrs" type="int_cmpl_quat">
       <configure name="USE_MAGNETOMETER" value="0"/>
       <define name="AHRS_USE_GPS_HEADING" value="1"/>
       <define name="AHRS_GRAVITY_UPDATE_COORDINATED_TURN"/>
    </module>

    <!-- Radio Control -->
    <module name="radio_control" type="ppm"/>

    <!-- Communication -->
    <module name="telemetry"     type="transparent"/>

    <!-- Navigation -->
    <module name="navigation"/>

    <!-- Actuators -->
    <module name="control"/>

    <module name="ins" type="alt_float"/>

    <module name="baro_ms5611_i2c_twin.xml">
      <define name="MS5611_I2C_DEV_1" value="i2c0"/>
      <define name="MS5611_I2C_DEV_2" value="i2c0"/>
      <define name="MS5611_SLAVE_ADDR_1" value="0xEE"/>
      <define name="MS5611_SLAVE_ADDR_2" value="0xEC"/>
      <define name="MS5611_KALMAN_Q" value=".5"/>
      <define name="MS5611_KALMAN_R" value="6."/>
      <define name="MS5611_AIRSPEED_SCALE_FACTOR" value="2.5"/>
      <define name="SENSOR_SYNC_SEND"/>
    </module>

    <module name="air_data.xml"/>
 </firmware>

 <firmware name="setup">
    <target name="tunnel"          board="twog_1.0"/>
    <target name="setup_actuators"   board="twog_1.0"/>
 </firmware>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel




_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel
Reply | Threaded
Open this post in threaded view
|

Re: GPS behavour after renaming subsystems to modules.

flixr
Administrator
Hi Helge,

you are absolutely right, in v5.8 this define is still needed for fixedwings (which need UTM).
We only refactored and cleaned that up afterwards in v5.9...

Should be fixed with v5.8.1_stable-10-gc9a9340

Thanks a lot for finding and reporting this!

Cheers, Felix

On Tue, Jun 21, 2016 at 10:49 AM, Helge Walle <[hidden email]> wrote:
Hi again, just an update.

I opened the file conf/modules/gps_ublox.xml and uncommented this line:
<define name="GPS_USE_LATLONG"/>

and then I got the ac and all waypoints on the screen/map ok.
Is this how it should be, or could it be something else in my setup?

Thanks, Helge.



2016-06-20 18:48 GMT+02:00 Helge Walle <[hidden email]>:
Thank you for your response Felix,

I just made two builds where the difference is only "subsystem" or "module" in the declaration in the gps line in the airframe file. The two makefiles (attached) are renamed to tell one from the other.

The files are a bit different. It seems the "module" makefile contains the gps build lines, while the "subsystem" makefile refers to the conf/firmwares/subsystems/fixedwing/gps_ublox.makefile. The order of the files gps_ubx.c and gps.c seems to appear different in the two cases. I don't know if this is relevant to the trouble I experience.

I am a bit over my head in this, maybe I need to spend some time looking more deeply into this myself. I have added a couple of my own modules for imu and baro, but no gps stuff.

Thanks, Helge.



2016-06-20 17:08 GMT+02:00 Felix Ruess <[hidden email]>:
Hi Helge,

that sounds very strange, since if no module of that name is available it will just use the subsystem as before.
You can also see this if you look at the generated $PAPARAZZI_HOME/var/aircrafts/<acname>/Makefile.ac

Don't have any idea what the reason could be for different behavior right now...

Felix

On Mon, Jun 20, 2016 at 2:00 PM, Helge Walle <[hidden email]> wrote:
Hi,
I am testing my airframe files after renaming subsystems to modules, and I get some problems with my GPS, which is a Navilock NL-552ettl. The GPS reports a fix in GCS, but the aircraft does not show up on the screen. The waypoints disappear from the screen one after the other after the fix is obtained.
In Paparazzi center, I repeatedly I get the message Invalid_argument("Latlong.of_utm").

When I build the aircraft with GPS as subsystem, I get this on the compiling list:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o

When I build the aircraft with GPS named as module, the order of the two lines are reversed and I get this:
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps.o
CC /home/helge/paparazzi/var/aircrafts/SKYWALKERHW_TWOG_V1_SEN10121_IMU/ap/subsystems/gps/gps_ubx.o

With GPS as subsystem everything works normally.

I am on version v5.8.1_stable-4-gbc4bff1.
Below is the firmware part of my airframe file.

Thans for any help,
Helge.


 <firmware name="fixedwing">
    <target name="ap"                                board="twog_1.0">
      <configure name="PERIODIC_FREQUENCY"           value="120"/>
      <configure name="AHRS_PROPAGATE_FREQUENCY"     value="100"/>
      <configure name="AHRS_CORRECT_FREQUENCY"       value="100"/>
      <define name="AHRS_TRIGGERED_ATTITUDE_LOOP" />
      <configure name="AHRS_ALIGNER_LED"             value="3"/>
      <configure name="CPU_LED"                      value="3"/>
      <define name="USE_I2C0"/>

      <define name="PERIOD_NAVIGATION_0"/><!-- stop NAVIGATION msg in main_ap.c -->
    </target>

    <target name="sim"                          board="pc"/>

    <!-- Global firmware defines -->
    <define name="LOITER_TRIM"/>
    <define name="AGR_CLIMB"/>
    <define name="WIND_INFO"/>
    <define name="WIND_INFO_RET"/>
    <define name="STRONG_WIND"/>

    <!-- Sensors -->
    <!-- <module name="gps"           type="ublox"/> -->
    <subsystem name="gps"           type="ublox"/>

    <module name="imu"           type="sen10121">
       <define name="IMU_SEN10121_ID" value="28"/>
    </module>
    <module name="ahrs" type="int_cmpl_quat">
       <configure name="USE_MAGNETOMETER" value="0"/>
       <define name="AHRS_USE_GPS_HEADING" value="1"/>
       <define name="AHRS_GRAVITY_UPDATE_COORDINATED_TURN"/>
    </module>

    <!-- Radio Control -->
    <module name="radio_control" type="ppm"/>

    <!-- Communication -->
    <module name="telemetry"     type="transparent"/>

    <!-- Navigation -->
    <module name="navigation"/>

    <!-- Actuators -->
    <module name="control"/>

    <module name="ins" type="alt_float"/>

    <module name="baro_ms5611_i2c_twin.xml">
      <define name="MS5611_I2C_DEV_1" value="i2c0"/>
      <define name="MS5611_I2C_DEV_2" value="i2c0"/>
      <define name="MS5611_SLAVE_ADDR_1" value="0xEE"/>
      <define name="MS5611_SLAVE_ADDR_2" value="0xEC"/>
      <define name="MS5611_KALMAN_Q" value=".5"/>
      <define name="MS5611_KALMAN_R" value="6."/>
      <define name="MS5611_AIRSPEED_SCALE_FACTOR" value="2.5"/>
      <define name="SENSOR_SYNC_SEND"/>
    </module>

    <module name="air_data.xml"/>
 </firmware>

 <firmware name="setup">
    <target name="tunnel"          board="twog_1.0"/>
    <target name="setup_actuators"   board="twog_1.0"/>
 </firmware>

_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel




_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel



_______________________________________________
Paparazzi-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/paparazzi-devel